网站首页 » Phpstorm » Phpstorm 更改php language level

Phpstorm 更改php language level

June 19, 2020 Phpstorm

使用phpstorm 在识别PHP7新特性时, 总是有提示问题,是选择的php language level 版本过低导致,如以下代码:

/**
     * 生成用户token
     * Function generateToken
     * author kevink
     * @param $user_id
     * @return string
     */
    public function generateToken($user_id =0 ) : array {
        if($user_id ==0 ) return false;
        $expireTime = time() + 3* 86400;
        $token = md5($this->key . $expireTime . $user_id . $this->key);
        return ['token' => $token, 'timestamp' => $expireTime , 'user_id' => $user_id];
    }

array 会出现提示~符号, 因为选择的php language level 版本过低,那我们就到phpstorm 中看看php 版本到底是多少。

Preferences > Languages & Frameworks > PHP.  发现php language level 是 php 5.4 。 这是phpstorm 默认的设置,我们改成7.1 及以上就可以了。 

这时有的朋友会发现,这里没法改呀。 那我们需要先修改一下别的地方,然后再回来改这里。 还是同样的路径 Preferences > Languages & Frameworks > PHP > Composer 。 找到Synchronize IDE Settings with composer.json

2020-06-19T02:36:18.png

将前面的√去掉, 保证显示如上图, 再回到修改php language level 的地方,发现已经可以修改成其他php版本了。

添加新评论